UI-Performance-Degradation

Resolved

This incident has been resolved.
Posted Sep 12, 2025 - 12:53 UTC

Identified

We identified that the Pendo API was causing slowness in UI page loading. We are applying fix
Posted Sep 12, 2025 - 08:36 UTC
This incident affected: UI.