Performance Degradation

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 15:25 UTC

Update

The database load unexpectedly spiked to 100%, causing noticeable application performance degradation. A rollout restart was performed, which successfully restored the database load to normal operating levels. We are currently investigating the underlying root cause and will continue to monitor the system closely. Operations have returned to normal, and the application is functioning as expected.
Posted Dec 11, 2025 - 15:24 UTC

Investigating

We are currently experiencing performance degradation affecting parts of our system. Our team has identified the issue and is actively working on a fix. Estimated time to resolution is approximately 40 minutes.

We will provide further updates soon. Thank you for your patience.
Posted Dec 11, 2025 - 13:41 UTC
This incident affected: UI, Compute and Reliability Dashboards, and Pipeline Observability.